$re = '/^(\\\\)(\\\\[\w\.\-_]+){2,}(\\\\?)$/m';
$str = '\\\\computer-name\\drive\\optional_folder1\\optional_folder2\\
\\\\computer_name\\drive\\optional_folder1\\
\\\\computer-name\\drive\\
\\\\192.168.1.1\\drive\\
\\\\computer-name\\\\drive\\
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);