# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[0-9]*,?[0-9]+(?=(?:(?!<\\/?p\b)[\s\S])*<\\/p>)/$1${2}1000000000000/g;t' <<< "I have 24.56 of something.
<a href=\"345.jpg\">345</a>
<p>abcdefg 1234,5 hijklmnop in 345 ddd.</p></br>
<p>abcdefg 5 hijklmnop<span style=\"some\">45,56</span>.</p></br>"