const regex = /[0-9]*,?[0-9]+(?=(?:(?!<\/?p\b)[\s\S])*<\/p>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]*,?[0-9]+(?=(?:(?!<\\\/?p\\b)[\\s\\S])*<\\\/p>)', 'g')
const str = `I have 24.56 of something.
<a href="345.jpg">345</a>
<p>abcdefg 1234,5 hijklmnop in 345 ddd.</p></br>
<p>abcdefg 5 hijklmnop<span style="some">45,56</span>.</p></br>`;
const subst = `$1${2}1000000000000`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);