#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[0-9]*,?[0-9]+(?=(?:(?!<\/?p\b)[\s\S])*<\/p>)"
Local $sString = "I have 24.56 of something." & @CRLF & _
"<a href="345.jpg">345</a>" & @CRLF & _
"<p>abcdefg 1234,5 hijklmnop in 345 ddd.</p></br>" & @CRLF & _
"<p>abcdefg 5 hijklmnop<span style="some">45,56</span>.</p></br>"
Local $sSubst = "$1${2}1000000000000"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)