import Foundation
let pattern = #"[0-9]*,?[0-9]+(?=(?:(?!<\/?p\b)[\s\S])*<\/p>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
I have 24.56 of something.
<a href="345.jpg">345</a>
<p>abcdefg 1234,5 hijklmnop in 345 ddd.</p></br>
<p>abcdefg 5 hijklmnop<span style="some">45,56</span>.</p></br>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1${2}1000000000000"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)