using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]*,?[0-9]+(?=(?:(?!<\/?p\b)[\s\S])*<\/p>)";
string substitution = @"$1${2}1000000000000";
string input = @"I have 24.56 of something.
<a href=""345.jpg"">345</a>
<p>abcdefg 1234,5 hijklmnop in 345 ddd.</p></br>
<p>abcdefg 5 hijklmnop<span style=""some"">45,56</span>.</p></br>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}