import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]*,?[0-9]+(?=(?:(?!<\\/?p\\b)[\\s\\S])*<\\/p>)";
final String string = "I have 24.56 of something.\n"
+ "<a href=\"345.jpg\">345</a>\n"
+ "<p>abcdefg 1234,5 hijklmnop in 345 ddd.</p></br>\n"
+ "<p>abcdefg 5 hijklmnop<span style=\"some\">45,56</span>.</p></br>";
final String subst = "$1${2}1000000000000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}