$re = '/[0-9]*,?[0-9]+(?=(?:(?!<\/?p\b)[\s\S])*<\/p>)/';
$str = 'I have 24.56 of something.
<a href="345.jpg">345</a>
<p>abcdefg 1234,5 hijklmnop in 345 ddd.</p></br>
<p>abcdefg 5 hijklmnop<span style="some">45,56</span>.</p></br>';
$subst = "$1${2}1000000000000";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;