#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\.f\.([A-Z]*?[a-z0-9]*?)([\s\);,])"
Local $sString = "test1.f.ABC, test2.f.XYZ, test3.f.PQR));"
Local $sSubst = "\.\L$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)