package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.f\.([A-Z]*?[a-z0-9]*?)([\s\);,])`)
var str = []byte(`test1.f.ABC, test2.f.XYZ, test3.f.PQR));`)
var substitution = []byte("\.\L$1$2")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}