use strict;
my $str = 'test1.f.ABC, test2.f.XYZ, test3.f.PQR));';
my $regex = qr/\.f\.([A-Z]*?[a-z0-9]*?)([\s\);,])/p;
my $subst = '\\.\\L$1$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";