# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\.f\.([A-Z]*?[a-z0-9]*?)([\s\);,])"
test_str = "test1.f.ABC, test2.f.XYZ, test3.f.PQR));"
subst = "\\.\\L$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.