import Foundation
let pattern = #"\.f\.([A-Z]*?[a-z0-9]*?)([\s\);,])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"test1.f.ABC, test2.f.XYZ, test3.f.PQR));"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\.\L$1$2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}