$re = '/\.f\.([A-Z]*?[a-z0-9]*?)([\s\);,])/';
$str = 'test1.f.ABC, test2.f.XYZ, test3.f.PQR));';
$subst = "\.\L$1$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;