import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.f\\.([A-Z]*?[a-z0-9]*?)([\\s\\);,])";
final String string = "test1.f.ABC, test2.f.XYZ, test3.f.PQR));";
final String subst = "\\.\\L$1$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}