// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\.f\.([A-Z]*?[a-z0-9]*?)([\s\);,])").unwrap();
let string = "test1.f.ABC, test2.f.XYZ, test3.f.PQR));";
let substitution = "\\.\\L$1$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}