# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(MATCH\s*\()COALESCE\(([^,)\s]+)(?:\s*,[^)]+)?\)/$1$2/gmi;t' <<< "WHERE MATCH (COALESCE(f1, f2, f3)) AGAINST (?) > 0
WHERE MATCH (COALESCE(f1)) AGAINST (?) > 0"