using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(MATCH\s*\()COALESCE\(([^,)\s]+)(?:\s*,[^)]+)?\)";
string substitution = @"$1$2";
string input = @"WHERE MATCH (COALESCE(f1, f2, f3)) AGAINST (?) > 0
WHERE MATCH (COALESCE(f1)) AGAINST (?) > 0";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}