$re = '/(MATCH\s*\()COALESCE\(([^,)\s]+)(?:\s*,[^)]+)?\)/mi';
$str = 'WHERE MATCH (COALESCE(f1, f2, f3)) AGAINST (?) > 0
WHERE MATCH (COALESCE(f1)) AGAINST (?) > 0';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;