package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(MATCH\s*\()COALESCE\(([^,)\s]+)(?:\s*,[^)]+)?\)`)
var str = `WHERE MATCH (COALESCE(f1, f2, f3)) AGAINST (?) > 0
WHERE MATCH (COALESCE(f1)) AGAINST (?) > 0`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}