const regex = /(MATCH\s*\()COALESCE\(([^,)\s]+)(?:\s*,[^)]+)?\)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(MATCH\\s*\\()COALESCE\\(([^,)\\s]+)(?:\\s*,[^)]+)?\\)', 'gmi')
const str = `WHERE MATCH (COALESCE(f1, f2, f3)) AGAINST (?) > 0
WHERE MATCH (COALESCE(f1)) AGAINST (?) > 0`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);