#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(MATCH\s*\()COALESCE\(([^,)\s]+)(?:\s*,[^)]+)?\)"
Local $sString = "WHERE MATCH (COALESCE(f1, f2, f3)) AGAINST (?) > 0" & @CRLF & _
"WHERE MATCH (COALESCE(f1)) AGAINST (?) > 0"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)