using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+<del.*?>.*?(<\/del>\w+|<\/del>))|(<del.*?>.*?<\/del>\w+)";
string input = @"<del>Within word</del>
WordEnd Tutorial<del class=""ice-del"">Within word</del> WordEndsample<del class=""ice-del"">total word</del>Welcome o RegExr v2.0 by gskinner.com!
Tutorial <del class=""del"">Within word</del>WordEnd sample <del class=""del"">total word</del> Welcome to the site!
Tutorial <del class=""del"">Within word</del>WordEnd sample<del class=""del"">total word</del> Welcome to the site!
Tutorial<del class=""del"">Within word</del>WordEnd sample <del class=""del"">total word</del> Welcome to the site!";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}