import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+<del.*?>.*?(<\\/del>\\w+|<\\/del>))|(<del.*?>.*?<\\/del>\\w+)";
final String string = "<del>Within word</del>\n"
+ "WordEnd Tutorial<del class=\"ice-del\">Within word</del> WordEndsample<del class=\"ice-del\">total word</del>Welcome o RegExr v2.0 by gskinner.com!\n\n"
+ "Tutorial <del class=\"del\">Within word</del>WordEnd sample <del class=\"del\">total word</del> Welcome to the site!\n"
+ "Tutorial <del class=\"del\">Within word</del>WordEnd sample<del class=\"del\">total word</del> Welcome to the site!\n"
+ "Tutorial<del class=\"del\">Within word</del>WordEnd sample <del class=\"del\">total word</del> Welcome to the site!";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}