import re
regex = re.compile(r"(\w+<del.*?>.*?(<\/del>\w+|<\/del>))|(<del.*?>.*?<\/del>\w+)")
test_str = ("<del>Within word</del>\n"
"WordEnd Tutorial<del class=\"ice-del\">Within word</del> WordEndsample<del class=\"ice-del\">total word</del>Welcome o RegExr v2.0 by gskinner.com!\n\n"
"Tutorial <del class=\"del\">Within word</del>WordEnd sample <del class=\"del\">total word</del> Welcome to the site!\n"
"Tutorial <del class=\"del\">Within word</del>WordEnd sample<del class=\"del\">total word</del> Welcome to the site!\n"
"Tutorial<del class=\"del\">Within word</del>WordEnd sample <del class=\"del\">total word</del> Welcome to the site!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")