$re = '/(\w+<del.*?>.*?(<\/del>\w+|<\/del>))|(<del.*?>.*?<\/del>\w+)/';
$str = '<del>Within word</del>
WordEnd Tutorial<del class="ice-del">Within word</del> WordEndsample<del class="ice-del">total word</del>Welcome o RegExr v2.0 by gskinner.com!
Tutorial <del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
Tutorial <del class="del">Within word</del>WordEnd sample<del class="del">total word</del> Welcome to the site!
Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);