import Foundation
let pattern = #"(\w+<del.*?>.*?(<\/del>\w+|<\/del>))|(<del.*?>.*?<\/del>\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<del>Within word</del>
WordEnd Tutorial<del class="ice-del">Within word</del> WordEndsample<del class="ice-del">total word</del>Welcome o RegExr v2.0 by gskinner.com!
Tutorial <del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
Tutorial <del class="del">Within word</del>WordEnd sample<del class="del">total word</del> Welcome to the site!
Tutorial<del class="del">Within word</del>WordEnd sample <del class="del">total word</del> Welcome to the site!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)