// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+<del.*?>.*?(<\/del>\w+|<\/del>))|(<del.*?>.*?<\/del>\w+)").unwrap();
let string = "<del>Within word</del>
WordEnd Tutorial<del class=\"ice-del\">Within word</del> WordEndsample<del class=\"ice-del\">total word</del>Welcome o RegExr v2.0 by gskinner.com!
Tutorial <del class=\"del\">Within word</del>WordEnd sample <del class=\"del\">total word</del> Welcome to the site!
Tutorial <del class=\"del\">Within word</del>WordEnd sample<del class=\"del\">total word</del> Welcome to the site!
Tutorial<del class=\"del\">Within word</del>WordEnd sample <del class=\"del\">total word</del> Welcome to the site!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}