#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*<parent>\n\s*<groupId>com\.ps\.consul\.releng<\/groupId>\n\s*<artifactId>com\.ps\.consul\.releng<\/artifactId>\n\s*<version>1\.0\.0-SNAPSHOT<\/version>\n\s*<relativePath>\.\.\/com\.ps\.consul\.releng<\/relativePath>\n\s*<\/parent>"
Local $sString = " <parent>" & @CRLF & _
" <groupId>com.ps.consul.releng</groupId>" & @CRLF & _
" <artifactId>com.ps.consul.releng</artifactId>" & @CRLF & _
" <version>1.0.0-SNAPSHOT</version>" & @CRLF & _
" <relativePath>../com.ps.consul.releng</relativePath>" & @CRLF & _
" </parent>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")