import Foundation
let pattern = #"\s*<parent>\n\s*<groupId>com\.ps\.consul\.releng<\/groupId>\n\s*<artifactId>com\.ps\.consul\.releng<\/artifactId>\n\s*<version>1\.0\.0-SNAPSHOT<\/version>\n\s*<relativePath>\.\.\/com\.ps\.consul\.releng<\/relativePath>\n\s*<\/parent>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<parent>
<groupId>com.ps.consul.releng</groupId>
<artifactId>com.ps.consul.releng</artifactId>
<version>1.0.0-SNAPSHOT</version>
<relativePath>../com.ps.consul.releng</relativePath>
</parent>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}