// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*<parent>\n\s*<groupId>com\.ps\.consul\.releng<\/groupId>\n\s*<artifactId>com\.ps\.consul\.releng<\/artifactId>\n\s*<version>1\.0\.0-SNAPSHOT<\/version>\n\s*<relativePath>\.\.\/com\.ps\.consul\.releng<\/relativePath>\n\s*<\/parent>").unwrap();
let string = " <parent>
<groupId>com.ps.consul.releng</groupId>
<artifactId>com.ps.consul.releng</artifactId>
<version>1.0.0-SNAPSHOT</version>
<relativePath>../com.ps.consul.releng</relativePath>
</parent>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}