import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*<parent>\\n\\s*<groupId>com\\.ps\\.consul\\.releng<\\/groupId>\\n\\s*<artifactId>com\\.ps\\.consul\\.releng<\\/artifactId>\\n\\s*<version>1\\.0\\.0-SNAPSHOT<\\/version>\\n\\s*<relativePath>\\.\\.\\/com\\.ps\\.consul\\.releng<\\/relativePath>\\n\\s*<\\/parent>";
final String string = " <parent>\n"
+ " <groupId>com.ps.consul.releng</groupId>\n"
+ " <artifactId>com.ps.consul.releng</artifactId>\n"
+ " <version>1.0.0-SNAPSHOT</version>\n"
+ " <relativePath>../com.ps.consul.releng</relativePath>\n"
+ " </parent>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}