using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*<parent>\n\s*<groupId>com\.ps\.consul\.releng<\/groupId>\n\s*<artifactId>com\.ps\.consul\.releng<\/artifactId>\n\s*<version>1\.0\.0-SNAPSHOT<\/version>\n\s*<relativePath>\.\.\/com\.ps\.consul\.releng<\/relativePath>\n\s*<\/parent>";
string input = @" <parent>
<groupId>com.ps.consul.releng</groupId>
<artifactId>com.ps.consul.releng</artifactId>
<version>1.0.0-SNAPSHOT</version>
<relativePath>../com.ps.consul.releng</relativePath>
</parent>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}