re = /\s*<parent>\n\s*<groupId>com\.ps\.consul\.releng<\/groupId>\n\s*<artifactId>com\.ps\.consul\.releng<\/artifactId>\n\s*<version>1\.0\.0-SNAPSHOT<\/version>\n\s*<relativePath>\.\.\/com\.ps\.consul\.releng<\/relativePath>\n\s*<\/parent>/
str = ' <parent>
<groupId>com.ps.consul.releng</groupId>
<artifactId>com.ps.consul.releng</artifactId>
<version>1.0.0-SNAPSHOT</version>
<relativePath>../com.ps.consul.releng</relativePath>
</parent>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end