# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/return([ \t]+([^"\n;]+))?;/{\g<0>}/;t' <<< "//please {return
[self funcA];}
return true;"