import re
regex = re.compile(r"return([ \t]+([^\"\n;]+))?;")
test_str = ("//please {return\n"
"[self funcA];}\n\n"
"return true;")
subst = "{\\g<0>}"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)