// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"return([ \t]+([^"\n;]+))?;"#).unwrap();
let string = "//please {return
[self funcA];}
return true;";
let substitution = "{\\g<0>}";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}