import Foundation
let pattern = #"return([ \t]+([^"\n;]+))?;"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
//please {return
[self funcA];}
return true;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{\g<0>}"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}