$re = '/return([ \t]+([^"\n;]+))?;/';
$str = '//please {return
[self funcA];}
return true;';
$subst = "{\g<0>}";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;