re = /return([ \t]+([^"\n;]+))?;/
str = '//please {return
[self funcA];}
return true;'
subst = '{\\g<0>}'
result = str.sub(re, subst)
# Print the result of the substitution
puts result