#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "return([ \t]+([^"\n;]+))?;"
Local $sString = "//please {return" & @CRLF & _
"[self funcA];}" & @CRLF & _
"" & @CRLF & _
"return true;"
Local $sSubst = "{\g<0>}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)