package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`return([ \t]+([^"\n;]+))?;`)
var str = []byte(`//please {return
[self funcA];}
return true;`)
var substitution = []byte("{\g<0>}")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}