$re = '/.*?\b(\d{2})\.(\d{2})\.(\d{4})\b/';
$str = 'Campaign on 01.11.2015';
$subst = "\3\2\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;