import Foundation
let pattern = #".*?\b(\d{2})\.(\d{2})\.(\d{4})\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Campaign on 01.11.2015"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\3\2\1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}