re = /.*?\b(\d{2})\.(\d{2})\.(\d{4})\b/
str = 'Campaign on 01.11.2015'
subst = '\\3\\2\\1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result