import re
regex = re.compile(r".*?\b(\d{2})\.(\d{2})\.(\d{4})\b")
test_str = "Campaign on 01.11.2015"
subst = "\\3\\2\\1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)