# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-zA-Z])[^.]*\.([a-zA-Z]).*?\b/\1.\2/g;t' <<< "New.York new.york "