package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z])[^.]*\.([a-zA-Z]).*?\b`)
var str = `New.York new.york `
var substitution = "\1.\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}