$re = '/([a-zA-Z])[^.]*\.([a-zA-Z]).*?\b/';
$str = 'New.York new.york ';
$subst = "\1.\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;