const regex = /([a-zA-Z])[^.]*\.([a-zA-Z]).*?\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z])[^.]*\\.([a-zA-Z]).*?\\b', 'g')
const str = `New.York new.york `;
const subst = `\1.\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);